SPECIAL OFFER! Get 1 year of access to everything in OSTraining for only $59! You save $85!
Join today and get access to 1,000's of books and videos. Learn WordPress, Drupal, Magento, Joomla and more! Sign up today!
Welcome, Guest
Username: Password: Remember me

TOPIC: Post-Installation Messages: Component Not Found

Post-Installation Messages: Component Not Found 3 years 7 months ago #109631

Hi -

When I log into the back end of a site I'm working on, I get this message:

You have post-installation messages
"There are important post-installation messages that require your attention. To view those messages please click on the Review Messages button below.
You can review the messages at any time by clicking on the Components, Post-installation messages menu item of your site's administrator section. This information area won't appear when you have hidden all messages."

When I click on the Review Messages button I get:

"An error has occurred. 404 component not found."

Also: When I select Components from the main menu, there is no submenu item that references post-installation messages.

How can I determine if there are any errors that need to resolved? And if there aren't, how can I prevent this message from appearing each time I sign in?'

Thanks for your help.

Kristin
Attachments:
  • Attachment This image is hidden for guests. Please log in or register to see it.
Please become a member of
OSTraining to reply to this post.

Post-Installation Messages: Component Not Found 3 years 7 months ago #109642

  • Nick
  • Nick's Avatar
  • OFFLINE
  • Posts: 23621
  • Thank you received: 695
Hi Kristin,

What specific Joomla version are you using? Once I have that information, I'll give you step-by-step directions on how to resolve the issue.

Looking forward to helping.

Kind regards,
Nick
Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of
OSTraining to reply to this post.

Post-Installation Messages: Component Not Found 3 years 7 months ago #109654

Hi Nick - It's Joomla 3.3.6.

Thanks!
Please become a member of
OSTraining to reply to this post.

Post-Installation Messages: Component Not Found 3 years 7 months ago #109663

  • Nick
  • Nick's Avatar
  • OFFLINE
  • Posts: 23621
  • Thank you received: 695
Thanks Kristin! Try these steps:

1) Create and download a backup:
www.ostraining.com/blog/joomla/test-site-akeeba-backup/

2) Fix your folder and file permission using Admin Tools:
www.ostraining.com/blog/joomla/admin-too...nd-file-permissions/

3) Download the following package:
github.com/joomla/joomla-cms/releases/do...e-Update_Package.zip

then install it from Extensions >> Extension Manager , as you would an extension.

4) Go to Extensions >> Extension Manager >> Database >> Fix

That should reset all your core files to 3.4.1 as well as your database.

5) Clear your browser's cache as well as your site cache.

Kind regards,
Nick
Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of
OSTraining to reply to this post.

Post-Installation Messages: Component Not Found 3 years 7 months ago #109668

Hi - Does the message I inquired about definitely have to do with the Joomla upgrade? I'm asking because I just (today, I think?) started getting a separate message about the Joomla upgrade, whereas the initial message has been there for some time. Plus, either way, I'm hesitant to upgrade because the site is built with a template and I don't know that the template is compatible with the newer version of Joomla.

Kristin
Please become a member of
OSTraining to reply to this post.

Post-Installation Messages: Component Not Found 3 years 7 months ago #109684

  • Nick
  • Nick's Avatar
  • OFFLINE
  • Posts: 23621
  • Thank you received: 695
Hi Kristin,

The issue's not necessarily from an upgrade, but the above process should resolve the issue.

As to your template, the upgrade should be 100% backwards compatible. All updates in the Joomla 3 series should work well for your template.

Hope this helps! Let us know if you have any questions and we'll be glad to answer.

Kind regards,
Nick
Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of
OSTraining to reply to this post.

Post-Installation Messages: Component Not Found 3 years 7 months ago #109727

OK, will try it. Thanks for your help!
Please become a member of
OSTraining to reply to this post.

Post-Installation Messages: Component Not Found 3 years 7 months ago #109729

  • Nick
  • Nick's Avatar
  • OFFLINE
  • Posts: 23621
  • Thank you received: 695
You're very welcome, Kristin! Let us know if you need any help along the way.

Cheers,
Nick
Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of
OSTraining to reply to this post.
Join today and get access to 1,000's of books and videos. Learn WordPress, Drupal, Magento, Joomla and more! Sign up today!