You can build great websites. We can help! You will get expert support and over 3,000 videos! Start a free trial!
Welcome, Guest
Username: Password:

TOPIC: Widget in Create Content issue

Widget in Create Content issue 3 years 4 months ago #70442

When I try to create a new content type the widget does not provide me with a dropdown list that's shown in the video. Instead it provides me with one choice to select.
This image is hidden for guests. Please log in or register to see it.



I can't move any further so can someone help.

Thanks,


Renee
Please become a member of
OSTraining to reply to this post.

Widget in Create Content issue 3 years 3 months ago #70488

  • steve
  • steve's Avatar
  • NOW ONLINE
  • Posts: 10809
  • Thank you received: 381
Hi rrosado

Yes, that's the normal Drupal behavior. Most of the options appear in the field to the left, in the Field Type column.

Could you tell me what options you were expecting to see in the column you've marked?
Please become a member of
OSTraining to reply to this post.

Widget in Create Content issue 3 years 3 months ago #71335

The widget doesn't show up where I can make selections. I can't rearrave mu fields because I don't have the bars to do so. Just curious why my installation looks different.
Please become a member of
OSTraining to reply to this post.

Widget in Create Content issue 3 years 3 months ago #71392

  • steve
  • steve's Avatar
  • NOW ONLINE
  • Posts: 10809
  • Thank you received: 381
Hi rrosado

Yes, I see what you mean.

I've come across also. I've seen it happen even on clean installations with no modules installed. Sometimes I could resolve the issue, sometimes I couldn't.

Could you try some of the suggestions here, please? drupal.org/node/675094

1) Disable the Theme Developer module if you have it installed
2) Click the "Hide Row Weights" link to remove the weights column from the display
3) Go to Configuration > Performance and turn off all the cache and optimization settings
Please become a member of
OSTraining to reply to this post.

Widget in Create Content issue 3 years 3 months ago #71791

i tried all of the methods. Nothing works.
Please become a member of
OSTraining to reply to this post.

Widget in Create Content issue 3 years 3 months ago #71852

  • steve
  • steve's Avatar
  • NOW ONLINE
  • Posts: 10809
  • Thank you received: 381
Yes, I've had that happen on a couple of sites for me also.

I've had to rely on the weights feature to re-arrange the fields.

There's a lot of people with the same problem here drupal.org/node/487934 and there's a variety of suggested fixes:

- replace the "/misc/tabledrag.js" file with a fresh version from the latest Drupal project download
- disable the Devel module
- bugshoot potential Javascript errors: drupal.org/node/487934#comment-3999614
Please become a member of
OSTraining to reply to this post.
You can build great websites. We can help! You will get expert support and over 3,000 videos! Start a free trial!