SPECIAL OFFER: Only $69 for access to everything in OSTraining for 1 year! You save $75!  1
Join today and get access to 1,000's of books and videos. Learn WordPress, Drupal, Magento, Joomla and more! Sign up today!

Language tag problem

7 years 8 months ago #88139 by johnniek2
Language tag problem was created by johnniek2
I am facing a problem with a language tag for a longer time. I have decided to search for some help here now :-)

my website is getting indexed from google regulary with the english language tag /en/ even the default language is english? I dont understand why if all my links when I click the navigation dont use the "en" tag.

For clarification my Split airport transfers subpage is: www.johnnie.hr/airport-transfers.html
but in google it gets indexed like: www.johnnie.hr/en/airport-transfers.html
even when I click it is opening: www.johnnie.hr/airport-transfers.html ???

I have an impression it has to do something with menu items etc. and language set to all and similar, but I am not able to get rid of that problem.

any idea?

Please Log in to join the conversation.

7 years 8 months ago - 7 years 8 months ago #88179 by Valentin
Replied by Valentin on topic Language tag problem
Hi johnniek2,

my website is getting indexed from google regulary with the english language tag /en/ even the default language is english? I dont understand why if all my links when I click the navigation dont use the "en" tag.

I would say is not the default one, is the most common
Your website uses "en-GB" as lang attribute in html tag ; Ctrl + U to see this in source code.

For clarification my Split airport transfers subpage is: www.johnnie.hr/airport-transfers.html
but in google it gets indexed like: www.johnnie.hr/en/airport-transfers.html
even when I click it is opening: www.johnnie.hr/airport-transfers.html ???

Some websites redirects automatically from a language url /en/ to a url without this data.
  • In the past, this website used /en/ in the url without redirecting?
  • Are you using a SEF extension?

UPDATE: your website seems to use english as default language. If you switch to another language, like /it/ (as example) this data can be removed from url. A good example is the home page of every Joomla site: the system avoid use the full url like index.php?option=com_content&view=featured&Itemid=101, instead use the domain name only.

Kind regards,
Valentín

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

7 years 8 months ago #88190 by johnniek2
Replied by johnniek2 on topic Language tag problem
Hi Valentin,

I must admit I didnt understand a word of your reply :-)
maybe because here its 11pm and I had two beers already....

but is there a way to not have en/ in my urls if thats my default language???

it is not possible to replicate in any of my navigation modules like menus?
I only find them in the sitemap and in google???

I use only RS SEO but it doesnt create the urls... Cheers :-)

Please Log in to join the conversation.

7 years 8 months ago #88199 by Nick
Replied by Nick on topic Language tag problem
Hi Johnnie,

Looks like it's a bug in Joomla. Your site is 303 redirecting the /en/ pages so that's why they are getting indexed in Google. It should instead be 301 redirecting them.

I was able to find the following bug report for the issue:
joomlacode.org/gf/project/joomla/tracker..._id=33194&start=8400

What specific Joomla version are you using?

We're looking forward to helping.

Kind regards,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

7 years 8 months ago #88209 by johnniek2
Replied by johnniek2 on topic Language tag problem
just updated to: 2.5.18
any idea how to fix this or should I wait for other updates?

Please Log in to join the conversation.

7 years 8 months ago #88245 by Nick
Replied by Nick on topic Language tag problem
Hi Johnnie,

My suggestion is to wait for an update, however the best course of action is to state that you have the same issue in the tracker item and offer to test any patches that come up at:
joomlacode.org/gf/project/joomla/tracker..._id=33194&start=8400

That will help speed up the process.

Also, you could implement the following temporary core hack in the mean time:
forum.joomla.org/viewtopic.php?p=2707599#p2742223

Kind regards,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

7 years 8 months ago #88249 by johnniek2
Replied by johnniek2 on topic Language tag problem
thanks Nick will give it a try

Please Log in to join the conversation.

7 years 8 months ago #88260 by Nick
Replied by Nick on topic Language tag problem
You're welcome, Johnnie! Let us know how it goes.

Kind regards,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

Join today and get access to 1,000's of books and videos. Learn WordPress, Drupal, Magento, Joomla and more! Sign up today!