SPECIAL OFFER: Only $69 for access to everything in OSTraining for 1 year! You save $75! 
Join today and get access to 1,000's of books and videos. Learn WordPress, Drupal, Magento, Joomla and more! Sign up today!

J 1.5.28 to J 3.5.1 redMIGRATOR migrate issue

5 years 5 months ago - 5 years 5 months ago #125713 by allfive
I'm referring to Barb's video "Joomla 1.5 to 3 migrator" where Barb is using redMIGRATOR 1.0. The only version available now is 1.6 and the pkg contents are different. I did install the component successfully on a fresh J 3.5.1 site with no sample data, but there is a problem. Clicking "options" after launching redMIGRATOR gives me an unstyled page populated with options fields (but is otherwise unresponsive) and displays the following at the bottom of the page:
Fatal error: Call to undefined method JFormFieldRadio::getRenderer() in /home/artsouth/public_html/abornew/libraries/joomla/form/fields/radio.php on line 53

Further questions arise with regard to the options fields for database options that Barb does not mention, but I'll wait for this reply before continuing.

Thank you.

Please Log in to join the conversation.

5 years 5 months ago - 5 years 5 months ago #125714 by allfive
Replied by allfive on topic J 1.5.28 to J 3.5.1 redMIGRATOR migrate issue
Update: the same error appears when I open the Global Configuration page. Pages like the Control Panel and System Configuration open file. Most other admin pages open fine, although I haven't checked all.
Fatal error: Call to undefined method JFormFieldRadio::getRenderer() in /home/artsouth/public_html/abornew/libraries/joomla/form/fields/radio.php on line 53

PHP 5.3.29

So maybe I should change the title of the post?

Please Log in to join the conversation.

5 years 5 months ago #125718 by Nick
Hi Don,

Looks like it's a bug in redCORE:
github.com/joomla/joomla-cms/issues/9663

Could you check with redMIGRATOR's developers about it? They should be able to get a release for it.

Hope this helps! Let us know if you have any questions and we'll be glad to answer.

Kind regards,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago - 5 years 5 months ago #125720 by allfive
Replied by allfive on topic J 1.5.28 to J 3.5.1 redMIGRATOR migrate issue
Thanks, Nick. Support is provided for paid subscribers only,

I did fill out the "customer service" email form (no support queries answered) and maybe they will respond. Otherwise I'm out of luck unless I call Denmark. :(

I tried disabling redMIGRATOR then uninstallling it but get this:
Error
Cannot uninstall redCORE because the following components are using it:
[com_redmigrator]

To others with this problem, you must disable and uninstall com_redmigrator first or you won't be able to uninstall any of their other plugins, etc.

The original error problem disappears when getting rid of the redMIGRATOR component.

Could you please point me to another migrator tool?

This is why I love Joomla! :)

Thanks.

Please Log in to join the conversation.

5 years 5 months ago #125722 by Nick
Hi Don,

Glad you got things sorted!

If possible, I would wait a few days and they should be able to release a new version by then if it's affecting all their Joomla 3.5 installs.

Alternatively, SP Upgrade is another great option:
extensions.joomla.org/extensions/extensi...migration/sp-upgrade

There are several more available at extensions.joomla.org/category/migration-a-conversion

Hope this helps! Let us know if you have any questions and we'll be glad to answer.

Kind regards,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
The following user(s) said Thank You: allfive

Please Log in to join the conversation.

5 years 5 months ago #125765 by allfive
Replied by allfive on topic J 1.5.28 to J 3.5.1 redMIGRATOR migrate issue
Nick,

Heard back from redcomponent. They've stopped development but put the project on github, if anyone wants to carry work on it.
github.com/redCOMPONENT-COM/redMIGRATOR

No activity on that forum for a year, though.

Since redMIGRATOR 1.6 is the only version available, might we conclude that J1.5 migrators who need to move to J 3.5.1 find another solution?

Thanks. :)

Please Log in to join the conversation.

5 years 5 months ago #125766 by Nick
Hi Don,

Based on that information, yes, that looks to be the case. I'd go with SP Upgrade in this situation.

I've also let you Video team know about the issue.

Thanks for the feedback, Don! We really appreciate it.

Kind regards,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
The following user(s) said Thank You: allfive

Please Log in to join the conversation.

Join today and get access to 1,000's of books and videos. Learn WordPress, Drupal, Magento, Joomla and more! Sign up today!