SPECIAL OFFER: Only $69 for access to everything in OSTraining for 1 year! You save $75!  1
Join today and get access to 1,000's of books and videos. Learn WordPress, Drupal, Magento, Joomla and more! Sign up today!

Problem getting from 2.5.4 to 3.4.8

3 years 8 months ago #125128 by dalberts
Problem getting from 2.5.4 to 3.4.8 was created by dalberts
Hey, I've got a - for me - big problem in the transition from 2.5.4 to 3.4.8. I took the wrong file when I would update and chose the full version 3.4.8 instead of the update version. Now I have tried several times to install and reinstall, but I get an error message. (I use FileZilla to transfer files between the database and my local PC). I tried to install the files I now present locally to another domain, and then it works - except that I do not get up articles, which I understand is in the database. I therefore wonder whether the fault may lie in the database.
The error code that comes up looks like this:

Warning: require_once(/customers/7/5/c/tursyklistene.no/httpd.www/plugins/system/vvisit_counterDShelperDSvvisit_counter.php): failed to open stream: No such file or directory in /customers/7/5/c/tursyklistene.no/httpd.www/plugins/system/vvisit_counter/vvisit_counter.php on line 18 Fatal error: require_once(): Failed opening required '/customers/7/5/c/tursyklistene.no/httpd.www/plugins/system/vvisit_counterDShelperDSvvisit_counter.php' (include_path='.:/usr/share/php') in /customers/7/5/c/tursyklistene.no/httpd.www/plugins/system/vvisit_counter/vvisit_counter.php on line 18

Please Log in to join the conversation.

3 years 8 months ago #125155 by Nick
Replied by Nick on topic Problem getting from 2.5.4 to 3.4.8
Hi and welcome, dalberts!

We'd be glad to help you sort this out. You're going to have to disable that plugin for now. Try this:
1) Go into phpMyAdmin
2) Your database
3) _extensions table
4) Search
5) Name -> LIKE %..%
6) for the Value set it to "count"
7) Find the vvisit_counter plugin and edit its enabled column to set it to 0.

Could you walk us through what steps you took? Did you unzip 3.4.8 in your Joomla root or did you use the backend Install area?

Kind regards,
Nick

p.s. For future reference, we have a class on this at www.ostraining.com/class/update-2/

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
The following user(s) said Thank You: dalberts

Please Log in to join the conversation.

3 years 8 months ago #125162 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
Hello, and thanks for the advice. I'll try this when I get home from work at midnight (Norwegian time).
The error arose when I tried to install 3.4.8 from the back end. Later I tried to unpack 3.4.8 on my desktop and install it using FileZilla. I may have made several mistakes in this (I am very new at joomla).
Best regards
dalberts

Please Log in to join the conversation.

3 years 8 months ago #125167 by Valentin
Replied by Valentin on topic Problem getting from 2.5.4 to 3.4.8
Hi dalberts,
Please try the Nick's suggestions and let us know how it goes.

Kind regards,
Valentín

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
The following user(s) said Thank You: dalberts

Please Log in to join the conversation.

3 years 8 months ago #125194 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
Hey, it's possible to be a little more specific in your description of what to do? I'm not very familiar with working in phpMyAdmin. I have opened the database and found «_extensions». I find nowhere to seek, and do not know exactly what to search for (you wrote: Name -> LIKE %..%). Then write "for the Value set it to" count "." There I also need help. I see no field called Value.
Best regards
Dalberts

Please Log in to join the conversation.

3 years 8 months ago #125196 by Valentin
Replied by Valentin on topic Problem getting from 2.5.4 to 3.4.8
Luckily, we have a class that will help you get started with phpMyAdmin.
The lesson about Search will help you in this matter.

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
The following user(s) said Thank You: dalberts

Please Log in to join the conversation.

3 years 8 months ago #125197 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
Splendid!!!

Please Log in to join the conversation.

3 years 8 months ago #125198 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
Now I have done what I was told to do.
This is what I see when I try to open in the back end:

Warning: require_once(/customers/7/5/c/tursyklistene.no/httpd.www/administrator/components/com_eventbooking/legacy/model.php): failed to open stream: No such file or directory in /customers/7/5/c/tursyklistene.no/httpd.www/components/com_eventbooking/models/reminder.php on line 13 Fatal error: require_once(): Failed opening required '/customers/7/5/c/tursyklistene.no/httpd.www/administrator/components/com_eventbooking/legacy/model.php' (include_path='.:/usr/share/php') in /customers/7/5/c/tursyklistene.no/httpd.www/components/com_eventbooking/models/reminder.php on line 13

When I search for "cont" under name, as you told me, I get a lot of results. Under "manifest_cache" they all sey:
{"legacy":false,"name":"Yj Ajax ... (and so on).
There is one module and 19 plugins.
Do I need to set them all to 0 in the enabled-row?

dalberts

Please Log in to join the conversation.

3 years 8 months ago #125199 by Nick
Replied by Nick on topic Problem getting from 2.5.4 to 3.4.8
Hi Dalberts,

Make sure it's "count" (with a u) rather than "cont" (which will find things like "continue".

You sound only set the one that has a name of "visit_counter" or something similar. That's the extension that has the error.

You can see it in this line of your original message:

Fatal error: require_once(): Failed opening required /plugins/system/vvisit_counterDShelperDSvvisit_counter.php' (include_path='.:/usr/share/php') in plugins/system/vvisit_counter/vvisit_counter.php on line 18


Hope this helps! Let us know if you have any questions and we'll be glad to answer.

Kind regards,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

3 years 8 months ago #125206 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
Hi
Now I understand the principles of search in the MySQL database. Thank you for telling. I'm learning a lot, and vil do your classes when I have time for it.
I've turned off (enabled) vvisit_counter (as you have told me), but I now receive the error message that you see below. After I god that message I also looked up com_eventbooking and enabled it. Still I get this error message when I try to open in the back end. The eventbooking isn't anyting I need in my Joomla-working. Is it so that I only should delete it?

best regards
dalberts

Warning: require_once(/customers/7/5/c/tursyklistene.no/httpd.www/administrator/components/com_eventbooking/legacy/model.php): failed to open stream: No such file or directory in /customers/7/5/c/tursyklistene.no/httpd.www/components/com_eventbooking/models/reminder.php on line 13 Fatal error: require_once(): Failed opening required '/customers/7/5/c/tursyklistene.no/httpd.www/administrator/components/com_eventbooking/legacy/model.php' (include_path='.:/usr/share/php') in /customers/7/5/c/tursyklistene.no/httpd.www/components/com_eventbooking/models/reminder.php on line 13

Please Log in to join the conversation.

3 years 8 months ago #125214 by Nick
Replied by Nick on topic Problem getting from 2.5.4 to 3.4.8
Hi Dalberts,

Great! Nice work!

Does the rest of your page work and you're just getting this ugly warning? If so, please give the following article a read:
www.ostraining.com/blog/joomla/warnings/

As you can see, notices don't present issues and can be ignored. You can and should change your error reporting to hide notices on a live site.

Hope this helps! Let us know if you have any questions and we'll be glad to answer.

Kind regards,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

3 years 8 months ago #125237 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
Hey, sorry to say, but right now I'm not getting into the page - either in the front end or in the back end.
When I try to enter in the back end I get this message: «tursyklistene.no page is not working». Because I get this I can't log on as an administrator. Therefore it is little I can use of those tips I found under "Notices, Warnings and Errors on Your Joomla Site".

One question: Do I find my articles somwhere in the MyPHP?
If so I'm thinking of rebuilding the whole site.

mest regards
dalberts

Please Log in to join the conversation.

3 years 8 months ago - 3 years 8 months ago #125247 by Valentin
Replied by Valentin on topic Problem getting from 2.5.4 to 3.4.8
Hi Dalberts,
  • Which was the last change you made before getting this issue?
  • Do you have a backup of your site before getting the problem?
About your question:

Do I find my articles somwhere in the MyPHP?

The articles are stored in the database.

Looking forward to help you

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
The following user(s) said Thank You: dalberts

Please Log in to join the conversation.

3 years 8 months ago #125249 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
Hi, the last change was that I - by accident - tried to install the whole 3.4.8 from the back end by usin the extention manager. I ment to install the update version from 2.5.4 to 3.0 which I found by joomla.org. When I dropped the zip-file into my back end it all stopped. Sinse then I've tried sveral times to install and re-install by using FileZilla. I have downloaded all files to my lokal pc, installed 3.4.8 the same way from my local pc (unpacked) and tried to load my old files on top of this.
All this worked fine when I tried it in another site (which was empty before I started). There I could see all my media stuff (pictures and videos), but none of my articles (that I now understand is to find in the MySql database).

I am sorry to say that I don't have an update backup. My lates bakup is from two years ago - made by Akeba.
It is in there somewhere.

If I can find my articles in the database; where do I find them? Is it possible to export them so that I can rebuild the site?

Then is my plan to empty the MySql and start from the beginning. I have all the zip-files for extentions on my local pc ready for installation.

If you go here: tursyklistene.no/administrator/
you can see the problem at the back end.

best regards
dalberts

Please Log in to join the conversation.

3 years 8 months ago - 3 years 8 months ago #125252 by Valentin
Replied by Valentin on topic Problem getting from 2.5.4 to 3.4.8

I ment to install the update version from 2.5.4 to 3.0

You needed to update from 2.5.4 to 2.5.28 before going to 3.0

I am sorry to say that I don't have an update backup. My lates bakup is from two years ago - made by Akeba.
It is in there somewhere.

May you ask to your hosting provider if they made backups? Hopefully you can restore your site to a working version.

If I can find my articles in the database; where do I find them? Is it possible to export them so that I can rebuild the site?

The articles are located in the #__content table from your database - where "#__" means the unique prefix of your database.

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

3 years 8 months ago #125257 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
Tanks for good advice. I have contacted my provider and waiting anxiously for a response if there is a good backup of the site. fingers crossed .
Best regards
Dalberts

Please Log in to join the conversation.

3 years 8 months ago #125268 by Valentin
Replied by Valentin on topic Problem getting from 2.5.4 to 3.4.8
Hi Dalberts,
good! Let us know if you receive a positive reply.

Kind regards,
Valentín

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

3 years 8 months ago #125847 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
Hi,
I have had problems with the domain www.tursyklistene.no after I - by mistake - tried to install joomla 3.4.8 directly to 2.5.4. (I used the extention manager for this).
Since then I have had problems (all described further up in this string).
I've read moustly all that's on your sides, and have tried everything. I also tried Akeeba and kickstart (I have a backup from 2014, but it didn't work).
Yesterday I deleted all files available in the filemanager (by using FileZilla), and reinstalled all files. (I have a copy on my local PC - the copy was taken after I got the problems).
Now I get the following error message (see below).
Is there anyone who can help me? What can I do to get the site operative?

Best regards
dalberts


This is the message I get when I try to open in the front end:

Deprecated: iconv_set_encoding(): Use of iconv.internal_encoding is deprecated in /customers/7/5/c/tursyklistene.no/httpd.www/libraries/joomla/string/string.php on line 28 Deprecated: iconv_set_encoding(): Use of iconv.input_encoding is deprecated in /customers/7/5/c/tursyklistene.no/httpd.www/libraries/joomla/string/string.php on line 29 Deprecated: iconv_set_encoding(): Use of iconv.output_encoding is deprecated in /customers/7/5/c/tursyklistene.no/httpd.www/libraries/joomla/string/string.php on line 30 Fatal error: Call to undefined method JHtml::getJSObject() in /customers/7/5/c/tursyklistene.no/httpd.www/libraries/cms/html/behavior.php on line 299

This is the message I get when I try to open in the back end:

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /customers/7/5/c/tursyklistene.no/httpd.www/libraries/joomla/filter/input.php on line 652 Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /customers/7/5/c/tursyklistene.no/httpd.www/libraries/joomla/filter/input.php on line 654 Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /customers/7/5/c/tursyklistene.no/httpd.www/libraries/joomla/filter/input.php:652) in /customers/7/5/c/tursyklistene.no/httpd.www/libraries/joomla/session/session.php on line 532 Deprecated: iconv_set_encoding(): Use of iconv.internal_encoding is deprecated in /customers/7/5/c/tursyklistene.no/httpd.www/libraries/joomla/string/string.php on line 28 Deprecated: iconv_set_encoding(): Use of iconv.input_encoding is deprecated in /customers/7/5/c/tursyklistene.no/httpd.www/libraries/joomla/string/string.php on line 29 Deprecated: iconv_set_encoding(): Use of iconv.output_encoding is deprecated in /customers/7/5/c/tursyklistene.no/httpd.www/libraries/joomla/string/string.php on line 30 Fatal error: Call to undefined method JHtml::getJSObject() in /customers/7/5/c/tursyklistene.no/httpd.www/libraries/cms/html/behavior.php on line 299

Please Log in to join the conversation.

3 years 8 months ago #125852 by Nick
Replied by Nick on topic Problem getting from 2.5.4 to 3.4.8
Hi dalberts,

Does everything else work or are you getting a white page too? If everything else works, checkout:
www.ostraining.com/blog/joomla/warnings/

If you're getting a white page, please try:
www.ostraining.com/blog/joomla/how-to-reset-joomla/

Looking forward to helping.

Kind regards,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
The following user(s) said Thank You: dalberts

Please Log in to join the conversation.

3 years 8 months ago #125858 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
Hi
I'm sorry to say, but I do not understand.
When I try to open the site this message (sent to you in the last message) is all that I can see - both in the front and the back end. It's not possible to log in. I can't se the login form.

I have hoped you could tell me what the messages means, and perhaps how I can solve the problem and be able to log in as an administrator in back end.
If you go to: www.tursyklistene.no
I think you will understand what I mean.

best regards
dalbert

Please Log in to join the conversation.

3 years 8 months ago #125859 by Nick
Replied by Nick on topic Problem getting from 2.5.4 to 3.4.8
Thanks for clarifying!

The messages you're seeing aren't the main issue. The main issue is the blank page underneath the messages.

Please give the following tutorial a try and it should fix it:
www.ostraining.com/blog/joomla/how-to-reset-joomla/

Hope this helps! Let us know if you have any questions and we'll be glad to answer.

Kind regards,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
The following user(s) said Thank You: dalberts

Please Log in to join the conversation.

3 years 8 months ago #125868 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
Hi, and thanks for good advices.

I read the whole tutorial of yours, and found that the only thing I could do was to download this:
Joomla_2.5.7-Stable-Update_Package.zip
I unpacked it on my pc and imported it in my FileZilla - as I was told to do.
Under you can see the result after this.

I think it's something wrong in the libraries-section (at least).
Do you have an good advice for this?

best regards
Dalberts

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /customers/7/5/c/tursyklistene.no/httpd.www/libraries/joomla/filter/input.php on line 652 Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /customers/7/5/c/tursyklistene.no/httpd.www/libraries/joomla/filter/input.php on line 654 Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /customers/7/5/c/tursyklistene.no/httpd.www/libraries/joomla/filter/input.php:652) in /customers/7/5/c/tursyklistene.no/httpd.www/libraries/joomla/session/session.php on line 532 Deprecated: iconv_set_encoding(): Use of iconv.internal_encoding is deprecated in /customers/7/5/c/tursyklistene.no/httpd.www/libraries/joomla/string/string.php on line 28 Deprecated: iconv_set_encoding(): Use of iconv.input_encoding is deprecated in /customers/7/5/c/tursyklistene.no/httpd.www/libraries/joomla/string/string.php on line 29 Deprecated: iconv_set_encoding(): Use of iconv.output_encoding is deprecated in /customers/7/5/c/tursyklistene.no/httpd.www/libraries/joomla/string/string.php on line 30 Fatal error: Call to undefined method JHtml::getJSObject() in /customers/7/5/c/tursyklistene.no/httpd.www/libraries/cms/html/behavior.php on line 299

Please Log in to join the conversation.

3 years 8 months ago #125869 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
Because I get this message - "modifier is deprecated". Could it be that the problem is because I once installed 3.x.x up on 2.5.7 (by accident)?
Is there perhaps a file here that I need to remove?

Please Log in to join the conversation.

3 years 8 months ago #125872 by Nick
Replied by Nick on topic Problem getting from 2.5.4 to 3.4.8
Hi Dalberts,

I think it would be better if we login and take a look for you. Would you send us some login credentials (both Joomla and cPanel) to support@ostraining.com so we can take a look for you? Also, please do two things for us:
1) In the email, include a link to this forum post
and
2) After sending the email, reply to this forum post letting us know you sent the email so that we can check it.

Looking forward to helping.

Kind regards,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

3 years 8 months ago #125876 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
Hi, there
Thanks for helping.
Now I have sent all the information you are asking for to the support email.
(I hope I understood what you were asking for)

I say again: you are very helpful!
And I am still learning a lot from you.

best regards
dalberts

crossing fingers

Please Log in to join the conversation.

3 years 8 months ago #125891 by Valentin
Replied by Valentin on topic Problem getting from 2.5.4 to 3.4.8
Hi Dalberts,

I renamed "installation" folder to something else to try to access the backend, however there are other issues that find hard to tackle.

The recommendation to upgrade from 2.5 to 3 is by first going to 2.5.28 (the last stable version of that series), then continue the upgrade to Joomla 3.

Do you have a backup of your site before trying to move to Joomla 3? It would be better if you can restore your site prior this issue, and try the upgrade as I commented above.

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

3 years 8 months ago #125902 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
Hi,
Do you mean that I should upgrade step by step from 2.5.7 to 2.5.28 - and then go from 2.5.28 to the first 3.x.x by using Filezilla? I can ty that. I have a backup on my local pc.

Please Log in to join the conversation.

3 years 8 months ago #125908 by Valentin
Replied by Valentin on topic Problem getting from 2.5.4 to 3.4.8
Yes! From 2.5.7 to 2.5.28, you can try this approach:

Download 2.5.28 zip package and install it as a regular extension from Extensions > Extension manager > Upload and Install

To upgrade to Joomla 3, we have a class that will provide you useful tips.

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

3 years 8 months ago #125912 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
OK. But I don't get into my extention manager the normal way.
Is there anonther way to do it?
Or do I unzip it om my pc and install it via FilZilla?
I suppose I can't use the installation file then? (I mean: I have to remove it from the unpacked files)

Please Log in to join the conversation.

3 years 8 months ago #125914 by Valentin
Replied by Valentin on topic Problem getting from 2.5.4 to 3.4.8

Or do I unzip it om my pc and install it via FilZilla?

Yes, that may works too.

Then in backend, go to Extensions > Extension manager > Database > "Fix" button

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

3 years 7 months ago #125992 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
Hey, now I have upgraded the site www.tursyklistene.no step by step from 2.5.7 to the very latest version.
I have used the patch files and install them using Filzilla.
But still I have an error on the page. If you go into the page and you'll understand what I mean.
I can still not get into the back end.

Now I need an advice:
Could this be an Joomla error, or is it an error in the server?
I have sent a request to the provider, and waiting for a response.

You can see the site here: www.tursyklistene.no

I'm sorri I have no attachment to send you.

best regards
dalberts

Please Log in to join the conversation.

3 years 7 months ago #125993 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
ooops...:
If you go into: tursyklistene.no/administrator/
you wil understand what I mean.

In the front end you will come to an login-form, but it will not work.

dalberts

Please Log in to join the conversation.

3 years 7 months ago #126000 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
Hi
I get this message when I try to open the page www.tursyklistene.no
Do you have any ide of what is wrong, and what I should do to repair it?


0 Argument 1 passed to JTableObserverTags::createObserver() must be an instance of JObservableInterface, instance of JTableContent given, called in /customers

Best regards
Dalberts

Please Log in to join the conversation.

3 years 7 months ago #126007 by Valentin
Replied by Valentin on topic Problem getting from 2.5.4 to 3.4.8
Hi Dalberts,

To summarize:

1) Did you updated to Joomla 2.5.28 first, right? Then to 3 following our class ?

2) Which was the last thing you did before getting the issue?

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

3 years 7 months ago - 3 years 7 months ago #126009 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
Hei
Yes, I uploaded Joomla to 2.5.28 - and then to 3 by following your class.
I did all this step by step from version to version in this way: I downloaded the upgrade version from Joomla, unzipped it on my pc and overwrote the old files by usin FilZilla (ftp).

But I had this problem not coming into the back end and the extention manager. Therefore I couldn't check if all of my extentions is up to date for 3.x.x.

The last ting I did - after installing the very last, and nothing happend - I uninstalled the configuration file, and installed the installation-package from the lates version of Joomla. Then it started the installationprogram, but as soon as I had finished that the site became as it is today.

Does this give you any more understanding of what is wrong?

best regards
dalberts

Please Log in to join the conversation.

3 years 7 months ago #126013 by Valentin
Replied by Valentin on topic Problem getting from 2.5.4 to 3.4.8

Therefore I couldn't check if all of my extentions is up to date for 3.x.x.

This part is highly important as explained in this lesson around 1:45 min .

I uninstalled the configuration file, and installed the installation-package from the lates version of Joomla.

The configuration.php file shouldn't be touched. May you elaborate this part?

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

3 years 7 months ago #126014 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
I understand it's important to check all exstentions while going from 2.5.28 to 3.x.x., but I don't get into the extention manager to do so.
Therefore I've tried to upgrade via FileZilla.

The confiuration-idea I got from this video:



It might be wrong, but I've tried it before in a training-zite of mine.

But you do not read any thing out of this string, as I asked for?:

0 Argument 1 passed to JTableObserverTags::createObserver() must be an instance of JObservableInterface, instance of JTableContent given, called in /customers

Please Log in to join the conversation.

3 years 7 months ago #126016 by Nick
Replied by Nick on topic Problem getting from 2.5.4 to 3.4.8
Hi dalberts,

Unfortunately, this is the step that messed it up:

The last ting I did - after installing the very last, and nothing happend - I uninstalled the configuration file, and installed the installation-package from the lates version of Joomla. Then it started the installationprogram, but as soon as I had finished that the site became as it is today.


That part isn't necessarily and what it does it re-installs Joomla without your previous data. Do you have a backup of your old configuration.php file? If so, please restore it.

Once restored, we can help you with the admin issue that you had.

Hope this helps! Let us know if you have any questions and we'll be glad to answer.

Kind regards,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

3 years 7 months ago #126023 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
OK. I'll try to find it.
It is on my original backup - the one I took several days ago. If I delete the existing configuration.php and reinstall the old one you migt be able to help. Di I understand you right?

Just one question: I god a message from my host telling that the cpanel is opend in the USA. That was you?

best regards
dalberts

Please Log in to join the conversation.

3 years 7 months ago #126025 by Nick
Replied by Nick on topic Problem getting from 2.5.4 to 3.4.8
Hi Dalberts,

Yes, that's correct.

Yes, I double checked your files right before replying. Assuming the timing lines up, that was very likely to be me that they noticed.

Kind regards,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

3 years 7 months ago #126029 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
Hi.
Now I have deleted the new configuration.php and reinstalled the old one from one month ago.

Before you go into my site I have to tell you:
I have tried several times to reinstall an install by using FileZilla. One of the times I wrote the same prefix in the installation that I found in the database. No I have files called a7ei4_ and bak_a7ei4_ in there. The files called bak_a7ei4_ is the original ones.
Today I have learned how to delete and rename files in the database. It some job, but I think I have to do it before I go further. What is your opinion on that?
(I'm still learning, as you see....)

Please Log in to join the conversation.

3 years 7 months ago #126032 by Nick
Replied by Nick on topic Problem getting from 2.5.4 to 3.4.8
Hi Dalberts,

OK, those bak_a8ei4_ tables would all have to be restored to their originals and the newly created ones by Joomla need to be deleted. This will restore your old site (except with the admin issue that you had which we'll help you resolve).

Kind regards,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

3 years 7 months ago #126037 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
Hi
Now I have deleted all files called "a7ei4_" and renamed til "bak_a7ei4_" to "a7ei4_" - one by one in the database.
(I'm learning the hard way - it was a lot job.)
I have also turned on the «PHP error messages» so that it's possible to see what's wrong, but I don't get any message either on the front end or in the back end.

best regards
dalberts

Please Log in to join the conversation.

3 years 7 months ago #126039 by Nick
Replied by Nick on topic Problem getting from 2.5.4 to 3.4.8
Thanks Dalberts!

Is it OK if we log in and take a look around now?

Looking forward to helping.

Kind regards,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

3 years 7 months ago #126041 by dalberts
Replied by dalberts on topic Problem getting from 2.5.4 to 3.4.8
Of course. Be my guest.
It's nearly night here in Norway now, so I'm login out for today.

best regards
dalberts, still learning a lot from you.

Please Log in to join the conversation.

3 years 7 months ago - 3 years 7 months ago #126043 by Nick
Replied by Nick on topic Problem getting from 2.5.4 to 3.4.8
Glad you're learning a lot, Dalberts!

Based on what I've observed while troubleshooting the site, my recommendation would be to start over from your backup. Restore the backup, then do the following:

1) Make sure you go to Joomla 2.5.28
2) Extensions -> Manage -> Database -> Fix -> Make sure it goes to 2.5.28
3) Go to administrator/components/com_admin/sql/updates/mysql and remove all the 1.7 files
4) Update all your extension to their latest versions. You currently have a lot that aren't running the latest versions and this is the main issue for the site being messed up during the update
5) Go to Components -> Joomla Update and update straight to Joomla 3.5.1

That should hopefully work well for you. Hope this helps! Let us know if you have any questions and we'll be glad to answer.

Kind regards,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

Join today and get access to 1,000's of books and videos. Learn WordPress, Drupal, Magento, Joomla and more! Sign up today!