SPECIAL OFFER: Only $69 for access to everything in OSTraining for 1 year! You save $75! 
Join today and get access to 1,000's of books and videos. Learn WordPress, Drupal, Magento, Joomla and more! Sign up today!

Joomla update and Akeeba backup issue

5 years 5 months ago #124903 by emilylu
Joomla update and Akeeba backup issue was created by emilylu
Hi,

I notice when I update my Joomla site from 3.4.8 to 3.5 it will bring up Akeeba Backup and create a backup of the site first before it proceed with the Joomla update.
While this works on some of my site but on another site I got an error message from Akeeba Backup see screenshot below. And then it will not perform the Joomla update... Is there a way I can bypass the Akeeba backup part now and proceed with Joomla 3.5 update? Is there a setting somewhere I can change to allow that? Thanks!

This message has an attachment image.
Please log in or register to see it.

Please Log in to join the conversation.

5 years 5 months ago #124904 by Valentin
Replied by Valentin on topic Joomla update and Akeeba backup issue
Hi Emily,
I recommend you to do a full site backup before any move. A full backup from your hosting provider may works too.

If Akeeba backup is giving you problems, be sure is up-to-date. If an update is missing, it will be available from Extensions > Manage > Update

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago #124905 by emilylu
Replied by emilylu on topic Joomla update and Akeeba backup issue
Hi Valentin,

Yes, I understand the importance of backup. However, this is our testing server (I'm running upgrade on test server first), plus we also have server snapshot that we can fall back on. So I think it's very safe to proceed with the Joomla 3.5 update without having the Akeeba backup. That's why I'm looking for a way to bypass it in this case.

Do you know of any ways that I can turn off that feature? This is the first time I see it's trying to run Akeeba before it will let me proceed with the Joomla update. That's why I;m asking.

Thanks.

Please Log in to join the conversation.

5 years 5 months ago #124909 by Valentin
Replied by Valentin on topic Joomla update and Akeeba backup issue
Thanks for the clarification! Yes, you can test the upgrade then.

Note, it requires to enable mbstring extension to run backups and other performs since is a minimum requirement for Joomla.

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago #124941 by emilylu
Replied by emilylu on topic Joomla update and Akeeba backup issue
Ok, so I've the mbstring installed and backup was successful... however, it still won't go to the Joomla update :(



So the process is like this:
I went and click on "update now" for Joomla 3.5, then it auto send me to create a backup in Akeeba. After few mins I'll get a message that the backup was successful then it just went back to Akeeba control panel. Then after I click on Joomla update button again, it repeat the whole process but NEVER actually update Joomla?!!

This message has an attachment image.
Please log in or register to see it.

Please Log in to join the conversation.

5 years 5 months ago #124942 by Nick
Replied by Nick on topic Joomla update and Akeeba backup issue
Hi Emily,

For now, you can disable the auto backup by going to:
1) Extensions
2) Plugins
3) Disable the "System - Akeeba Backup Update Check" plugin.

Hope this helps! Let us know if you have any questions and we'll be glad to answer.

Kind regards,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago #124943 by emilylu
Replied by emilylu on topic Joomla update and Akeeba backup issue
Very odd. It was disabled. See screenshot below.



So I try "enable" it, then run the update again, same things happens... tried clean site cached too and didn't work either. Any other ideas?? Thanks!

This message has an attachment image.
Please log in or register to see it.

Please Log in to join the conversation.

5 years 5 months ago #124944 by Nick
Replied by Nick on topic Joomla update and Akeeba backup issue
Would you send us some login credentials to support@ostraining.com so we can take a quick look for you? Also, please do three things for us:
1) In the email, include a link to this forum post
2) In the email, include step by step direction of how to replicate the issue.
3) After sending the email, reply to this forum post letting us know you sent the email so that we can check it.

Looking forward to helping.

Kind regards,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago #124946 by emilylu
Replied by emilylu on topic Joomla update and Akeeba backup issue
Nick - I just email you the info. Please help! Thanks!

Please Log in to join the conversation.

5 years 5 months ago #124949 by Nick
Replied by Nick on topic Joomla update and Akeeba backup issue
Thanks Emily!

In Plugin Manager, disable the following plugin too:
System - Backup on update

Then it should work for you :)

Cheers,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
The following user(s) said Thank You: emilylu

Please Log in to join the conversation.

5 years 5 months ago #124950 by emilylu
Replied by emilylu on topic Joomla update and Akeeba backup issue
Yes, that does work! and the update has been completed for Joomla 3.5.
Now, should I re-enable that plugin? both system backup and akeeba??
Also, after Joomla update compeleted I got another extension update (I didn't get this one on the other site), should I go ahead with it? Thank you so much!!!

This message has an attachment image.
Please log in or register to see it.

Please Log in to join the conversation.

5 years 5 months ago #124951 by Nick
Replied by Nick on topic Joomla update and Akeeba backup issue
Great! Glad to hear that.

Your first one doesn't appear to be working and is showing as uninstalled. I would say you can re-enable the second one at some point and then hopefully Nicholas will release an update for AkeebaBackup with the fix.

Sure thing, go ahead and update it.

Kind regards,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago #124952 by emilylu
Replied by emilylu on topic Joomla update and Akeeba backup issue
Hum, so it was a bug with Akeeba that caused my issue with Joomla Update? That's odd too since I didn't get that issue on my other Joomla site!

But I'm so glad you found a workaround. Thank you again for that!

Please Log in to join the conversation.

5 years 5 months ago #124953 by Nick
Replied by Nick on topic Joomla update and Akeeba backup issue
I'm not sure that it caused it, but running the backup didn't allow for the update to start/complete. So it appears to be a bug in Akeeba but it might be elsewhere instead. It's worth checking with Akeeba's support on it and reporting the issue to them.

You're very welcome, Emily! :)

Kind regards,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago #125261 by Madcockney
Replied by Madcockney on topic Joomla update and Akeeba backup issue
Just one thing worth looking at is if all the sites are running the same versions of php as that may be an issue between the ones that work and those that don't. The version shown on the screen shot is php 4. I know Joomla 3 can handle php 4 but the version of Akeeba Backup may need a particular minimum php version that is higher than that. On Nicholas's site he states what the minimum version is for each version of Akeeba Backup.

Please Log in to join the conversation.

5 years 5 months ago #125272 by Valentin
Replied by Valentin on topic Joomla update and Akeeba backup issue
Hi Madcockney,

That's correct. The page that displays the PHP compatibility is here .

Thanks for sharing your thoughts!

Kind regards,
Valentín

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

Join today and get access to 1,000's of books and videos. Learn WordPress, Drupal, Magento, Joomla and more! Sign up today!