SPECIAL OFFER: Only $69 for access to everything in OSTraining for 1 year! You save $75! 
Join today and get access to 1,000's of books and videos. Learn WordPress, Drupal, Magento, Joomla and more! Sign up today!

Problems updating from Joomla 3.4.8 to 3.5

5 years 5 months ago #124798 by savethefrogs
Problems updating from Joomla 3.4.8 to 3.5 was created by savethefrogs
Hi,
I have tried to twice to update but it gets hung up (see attached screenshot). Any suggestions?
Akeeba Backup automatically took a backup when I clicked update; that went well, but it goes no further than the current state. Right now it has been an hour. Last night it went hours and got nowhere.
Thanks, Kerry

This message has an attachment image.
Please log in or register to see it.

Please Log in to join the conversation.

5 years 5 months ago #124801 by Valentin
Replied by Valentin on topic Problems updating from Joomla 3.4.8 to 3.5
Hi Kerry,

Please make a fullsite backup before trying again the update.

Fix file permissions

Then try the update again.

Kind regards,
Valentín

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago #124807 by savethefrogs
Replied by savethefrogs on topic Problems updating from Joomla 3.4.8 to 3.5
That worked, thank you!

Please Log in to join the conversation.

5 years 5 months ago #124812 by Nick
Hi Kerry,

Great! We're glad the permissions fix worked for you.

If you encounter any other issues, let us know and we'll be happy to help.

Cheers,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago #124838 by KarmicVisions
Replied by KarmicVisions on topic Problems updating from Joomla 3.4.8 to 3.5
I'm also having an issue:
ERROR: AJAX Loading Error: Forbidden

I did the fix permissions but still get this error. In the past my work around was to install the update but that doesn't work on this one.

I also uploaded the file to the tmp folder and extracted but still get stuck here.

Please Log in to join the conversation.

5 years 5 months ago #124843 by KarmicVisions
Replied by KarmicVisions on topic Problems updating from Joomla 3.4.8 to 3.5
Wow apparently siteground is not allowing updates now, in the middle of my upgrades.

They said:
"We have found a lot security problems into the latest version of joomla which is on version 3.5 and above
We have already report it to joomla and to protect our users we have stopped currently the updates of all joomla website on all our hosting "

Since I've had the ajax error for a while, I don't think that is caused be them but tech support wouldn't help since they are not wanting the upgrades to be done.

If you have any suggestions regarding the ajax issue would greatly appreciate the help!
Thanks,
Darlene

Please Log in to join the conversation.

5 years 5 months ago #124844 by Valentin
Replied by Valentin on topic Problems updating from Joomla 3.4.8 to 3.5
Hi Darlene,
I'm surprised about that advice.

Did they mentioned further details?

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago #124848 by KarmicVisions
Replied by KarmicVisions on topic Problems updating from Joomla 3.4.8 to 3.5
No, I copied that from the chat so they were very clear about not upgrading. I was about half way through all my websites so I don't know how to proceed, but since I'm on their hosting account I don't think I'll be able to do anything else. I just hope I don't have to downgrade the other sites. And of course I don't want the upgraded sites hacked either.

Please Log in to join the conversation.

5 years 5 months ago #124851 by Valentin
Replied by Valentin on topic Problems updating from Joomla 3.4.8 to 3.5
Since your hosting provider doesn't allow you to update Joomla for those reasons, my advice is to follow their advice, since they have the control of your sites.

If you receive any update from them, let us know.

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago #124852 by KarmicVisions
Replied by KarmicVisions on topic Problems updating from Joomla 3.4.8 to 3.5
I've submitted a support ticket, so perhaps I'll get more information in that regard and I'll update.

Please Log in to join the conversation.

5 years 5 months ago #124858 by Valentin
Replied by Valentin on topic Problems updating from Joomla 3.4.8 to 3.5
Wonderful! Let us know how it goes.

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago #124892 by KarmicVisions
Replied by KarmicVisions on topic Problems updating from Joomla 3.4.8 to 3.5
So the heart of their response:

"However, currently we are experiencing some issue with the latest release of Joomla core. We have contacted the Joomla developers and they are working on the case.

Once they are done, the new Joomla 3.5 release will be available in our tool for upgrading. I am afraid that I cannot provide you with exact ETA when the issue will be resolved."

This seems a little more gray in regard to the issue but it would appear we are waiting for an update to the update.

Please Log in to join the conversation.

5 years 5 months ago #124894 by Valentin
Replied by Valentin on topic Problems updating from Joomla 3.4.8 to 3.5
Hi Darlene,
Yes, that seems to be the case.

Since they mention security issues, it is important to keep the very details in private while a solution is available.

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago #124895 by KarmicVisions
Replied by KarmicVisions on topic Problems updating from Joomla 3.4.8 to 3.5
Yes, of course. Feel free to delete my posts if need be.

Please Log in to join the conversation.

5 years 5 months ago #124898 by Valentin
Replied by Valentin on topic Problems updating from Joomla 3.4.8 to 3.5
Let us know if you receive any update from your hosting provider.

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago #124994 by honeyflowfarm
Replied by honeyflowfarm on topic Problems updating from Joomla 3.4.8 to 3.5
I also have a problem updating. The update on the "joomla Update" component worked just fine, and the new site said I was on Joomla 3.5 ... But... this is what the frontend displayed:

I went back to the before update backup and all ok now.
I did see red areas on my cpanel when backing up:



On a different site - same Midphase but different account the update to 3.5 went just fine. Is this a Joomla 3.5 problem? Should we just wait a while for another update?

This message has attachments images.
Please log in or register to see it.

Please Log in to join the conversation.

5 years 5 months ago #124999 by Valentin
Replied by Valentin on topic Problems updating from Joomla 3.4.8 to 3.5
Hi honeyflowfarm,

Can you ask to your hosting provider to switch to PHP 7, hopefully that will solve the issue.

Kind regards,
Valentín

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago #125012 by honeyflowfarm
Replied by honeyflowfarm on topic Problems updating from Joomla 3.4.8 to 3.5
I just received this back from midphase:

"Thank you for contacting Midphase Support!
Unfortunate our shared servers are on a set upgrade schedule, we cannot up or downgrade them for one client. We are running the most current stable version of PHP. If you require something else, you may want to look into a dedicated or VPS, on there you can put whatever you need, however you will have to do everything, including installing cpanel."

I am on PHP 5.6.18 right now. The other site where I successfully installed joomla3.5 also is on php 5.6.18

Please Log in to join the conversation.

5 years 5 months ago #125013 by KarmicVisions
Replied by KarmicVisions on topic Problems updating from Joomla 3.4.8 to 3.5
I recommend siteground for hosting, you don't have that issue.

Please Log in to join the conversation.

5 years 5 months ago #125016 by Nick
Hi honeyflowfarm,

Please give this tutorial a try:
www.ostraining.com/blog/joomla/how-to-reset-joomla/

If that doesn't fix the issue, then it's likely a backward compatibility break with an extension that you have installed. We can help you narrow it down if that's the case. Just let us know what result you get after trying the above tutorial.

Your home page is working well for me, by the way. Did you happen to get the issue resolved?

Kind regards,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago #125039 by honeyflowfarm
Replied by honeyflowfarm on topic Problems updating from Joomla 3.4.8 to 3.5
Hello All

I followed the instructions on the reset page and still have a problem.

1 - I fixed the file permissions – but it took about 45 minutes to complete.
2 - Did the joomla3.4.8 update ok
3 – Tried to fix database but still had an error (attach image) (Note – when I was temporarily upgraded to jooml3.5, I
went to the database section and eventually the error got fixed?)



4 – used the upgrade component to upgrade to joomla3.5
This is the error I get on front page (on all browsers)
“Fatal error: Using $this when not in object context in /home/wwwhoney/public_html/libraries/joomla/filter/input.php on line 233”

5 – Then I reloaded the site using akeeba and made another new backup.

The site you saw was the reloaded 3.4.8 site.

This message has an attachment image.
Please log in or register to see it.

Please Log in to join the conversation.

5 years 5 months ago #125051 by honeyflowfarm
Replied by honeyflowfarm on topic Problems updating from Joomla 3.4.8 to 3.5
I thought I had it fixed but no – I updated a different site in a subdomain (same template) and found the sh404 was a “required”update for joomla 3.5 – I updated everything and the update to joomla3.5 went fine – ON THIS SITE

Then on my main site – I did the same thing – did all on your cleanup link – fixed file permisions – reinstalled 3.4.8 – and removed or upgraded everything - only thing left was one item left called "template framework (I even re-installed the template. I still have the same database error left. – then I backed up the site again with all these updates. --- then Finally ran the Joom3.5 update – still no joy – had this on the front end:
“Fatal error: Using $this when not in object context in /home/wwwhoney/public_html/libraries/joomla/filter/input.php on line 233”

I am in the process of re-installing the backup again and then I am putting a copy in a folder for further work and instructions.

Please Log in to join the conversation.

5 years 5 months ago #125066 by Valentin
Replied by Valentin on topic Problems updating from Joomla 3.4.8 to 3.5
Hi honeyflowfarm,

What is the PHP version being used for this site?

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago #125073 by honeyflowfarm
Replied by honeyflowfarm on topic Problems updating from Joomla 3.4.8 to 3.5
PHP Version 5.6.18 - I just updated joomla3.5 on 2 other sites on midphase with the same PHP Version 5.6.18 . I have a shared server and cannot update right now - anyway joom3.5 works fine on this server. One of the sites is in a subdomain on the site with a problem and it works fine.

Please Log in to join the conversation.

5 years 5 months ago #125078 by Valentin
Replied by Valentin on topic Problems updating from Joomla 3.4.8 to 3.5
That's good to hear!

Note, some hosting providers with shared hosting allow you to define a different PHP version in each folder. It is something worth to check with yours.

Have a good day!

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago #125080 by honeyflowfarm
Replied by honeyflowfarm on topic Problems updating from Joomla 3.4.8 to 3.5
They already said they could not do it - besides Joomla3.5 IS WORKING ON MY SITE IN A SUBFOLDER

Please Log in to join the conversation.

5 years 5 months ago #125082 by Valentin
Replied by Valentin on topic Problems updating from Joomla 3.4.8 to 3.5
That's good!

I just published a short tutorial to explain better my suggestion above. I guess your hosting provider doesn't have that feature.

Have a good day!

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago #125085 by honeyflowfarm
Replied by honeyflowfarm on topic Problems updating from Joomla 3.4.8 to 3.5
Thank you - I just looked at that tutorial and I did not see that option on my CPanel.

I just installed a copy of the site in a subfolder. I just noticed that they are both using the same database. Is that a problem? Should I reinstall it making a new database? Or is it ok for now? Right now I have a test version of the site that I can experiment with.

What should I do next? (Everything is working ok on the live site - so there is no emergency)

Please Log in to join the conversation.

5 years 5 months ago #125086 by Valentin
Replied by Valentin on topic Problems updating from Joomla 3.4.8 to 3.5

I just installed a copy of the site in a subfolder. I just noticed that they are both using the same database. Is that a problem?

If the database prefix of both sites are different, it shouldn't be a problem. However I recommend to have separate databases, one for each Joomla installation in order to keep things organized.

As long as the sites works as expected, you should be fine.

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago #125694 by KarmicVisions
Replied by KarmicVisions on topic Problems updating from Joomla 3.4.8 to 3.5
So with the new version out I'm trying to make the updates that I didn't get resolved before.
Still having this issue:
ERROR: AJAX Loading Error: Forbidden

I did the fix permissions but still get this error. In the past my work around was to install the update but that doesn't work on this one.

I also uploaded the file to the tmp folder and extracted but still get stuck here.

I don't know what else to look at to figure out why this seems to always happen on this website.

Please Log in to join the conversation.

5 years 5 months ago #125699 by Valentin
Replied by Valentin on topic Problems updating from Joomla 3.4.8 to 3.5
Hi KarmicVisions,
You moved to Joomla 3.5.0 and these issues came up?

If that's the case, please go to Components > Joomla update and install the recent update for Joomla 3.5.1
Fix permissions and see if makes a difference.

Looking forward to help you

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago #125705 by KarmicVisions
Replied by KarmicVisions on topic Problems updating from Joomla 3.4.8 to 3.5
No this happens on any joomla update using that update feature.
Used Akeeba's admin for permissions fix and still throws that error on two sites.
I did get the siteground update feature to work but would like to fix whatever is causing the error.

Please Log in to join the conversation.

5 years 5 months ago - 5 years 5 months ago #125709 by Valentin
Replied by Valentin on topic Problems updating from Joomla 3.4.8 to 3.5

No this happens on any joomla update using that update feature.

It seems Siteground had some problems with the Joomla 3.5 update and they were waiting for a new Joomla version that fixed the problem.

Would you mind contacting them to see if that issue was resolved, or if you need to wait until they fix it.

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago #125711 by Nick
Hi Darlene,

Could you try disabling your .htaccess for a moment then seeing if you still get the error? Seems like something is blocking the request and I suspect it's server related.

Kind regards,
Nick

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 5 months ago #125726 by KarmicVisions
Replied by KarmicVisions on topic Problems updating from Joomla 3.4.8 to 3.5
Thanks guys, but I had already found a work around on the two sites so I can't test the htaccess at this point but when there is a new update I'll try disabling it and see if that's the issue.

Things worked fine through siteground and this appears to have been the update they were waiting on.

Thanks again!

Please Log in to join the conversation.

5 years 5 months ago #125730 by Valentin
Replied by Valentin on topic Problems updating from Joomla 3.4.8 to 3.5
Wonderful!

Let us know if we can help you in something else

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

Join today and get access to 1,000's of books and videos. Learn WordPress, Drupal, Magento, Joomla and more! Sign up today!