SPECIAL OFFER: Only $69 for access to everything in OSTraining for 1 year! You save $75!  1
Join today and get access to 1,000's of books and videos. Learn WordPress, Drupal, Magento, Joomla and more! Sign up today!

Links to articles don't work after attack & repair

5 years 9 months ago #121113 by eguido
Hi, Several of my Joomla sites were hacked and the host server used Site Doctor to repair the damages. All appears to be working except this one, where the links to articles are not working. Links to external sites work. Host server said there does not appear to be anything wrong from the backend. I'm not sure if you can help me to get it to working condition again. The site is: busybodyhealth.com. This is a Joomla 2.5.28 site. Thank you. Emily

Please Log in to join the conversation.

5 years 9 months ago #121115 by jmc
Hi
Have you tried going to Menu and clicking on the rebuild menu option.

Mark

Please Log in to join the conversation.

5 years 9 months ago #121123 by eguido
Hi, I just tried. It didn't make any difference. Thank you.

Please Log in to join the conversation.

5 years 9 months ago #121135 by jmc
That is a pity. My computer security software is stopping me visiting your site today. Are you sure it is now "clean" - have you tried using myjoomla.com/ as a check.

Mark

Please Log in to join the conversation.

5 years 9 months ago #121153 by eguido
Hi, Thanks for the link. I did run a free check and several issues came up. One of the item s is to upgrade to the most current version (3.x). I was wondering if I should fix the problem before I upgrade? Or the upgrade will fix the problem? Also, I don't know if I should do the upgrade myself or subscribe to their monthly subscription (5 euro/mon). Do you know if the monthly subscription will fix all the problems?
Thank you! Emily

Please Log in to join the conversation.

5 years 9 months ago #121161 by Valentin
Hi Emily,

Before making any suggestion, may I know which specific links are broken?

Kind regards,
Valentín

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 9 months ago #121163 by eguido
Hi Valentin,

Sure. Please look at this one: busybodyhealth.com/index.php/recipes/foo...ocolate-chip-cookies
I have not check ALL the articles. But every articles that I've looked is like that above.

So, I'm in the process of creating a test development site to get ready to migrate from my current 2.5.28 to 3.x. I'm going thru the video instruction here: www.ostraining.com/courses/session/jooml...oomla/videos/backup/

However, when I am uploading the Akeeba Kickstart zip file to my site, an error msg appeared (attached).


I don't know if it is related.

Thank you.
Emily

Please Log in to join the conversation.

5 years 9 months ago - 5 years 9 months ago #121173 by Valentin
Go to System > Global configuration > Server > Error reporting: maximum
Refresh the link and share the error displayed.

Kind regards,
Valentín

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 9 months ago #121176 by eguido
Valentin,

I'd followed your instruction & then tried to reload Kickstart and got this error message.



Thank you.
Emily

This message has an attachment image.
Please log in or register to see it.

Please Log in to join the conversation.

5 years 9 months ago - 5 years 9 months ago #121179 by Valentin
I was looking for the front-page. See the errors here: busybodyhealth.com/index.php/recipes/foo...ocolate-chip-cookies

Ignore the "Strict Standards" mentions, the "Deprecated" ones are causing the problems. I see those errors mention a SEO plugin, which should affect the URLs.

Are you using this extension, right? extensions.joomla.org/extension/seosimple
If that's the case, go to Extensions > Plugin manager
Search "SEO Simple" and disable it.

Also, don't forget to change Error reporting to "Default" or "None"

Hopefull those changes would fix the issues

Kind regards,
Valentín

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 9 months ago #121180 by eguido
Valentin,

You have pinpointed the issue right on! By disabling the seosimple, I can see the articles correctly. Yay! Thank you!

Akeeba Kickstart zip file still will not upload. It must be another issue. I will submit another ticket for that. Thanks so much!

Emily

Please Log in to join the conversation.

5 years 9 months ago #121182 by Valentin
Wonderful! :)

Please create a new topic with the details about the Akeeba kickstart issues. We will reply as soon as possible.

Kind regards,
Valentín

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

Join today and get access to 1,000's of books and videos. Learn WordPress, Drupal, Magento, Joomla and more! Sign up today!