SPECIAL OFFER: Only $69 for access to everything in OSTraining for 1 year! You save $75! 
Join today and get access to 1,000's of books and videos. Learn WordPress, Drupal, Magento, Joomla and more! Sign up today!

Are PHP versions backwards compatible in Joomla?

5 years 11 months ago #120432 by allfive
I'm upgrading my 1.5.x site to 3.x and my current, live 1.5 site is running PHP version 5.2. I need PHP 5.5 or 5.6 for my J3 upgrade dev site. Will the live Joomla! 1.5 site run on PHP 5.6 while I work on the J3 upgrade installation?

IOW, is PHP backwards compatible? If not, how do I upgrade to J3 while running J1.5 on my server?

Obviously I don't understand basic PHP implementation on the server.

Thank you.

Please Log in to join the conversation.

5 years 11 months ago #120441 by Valentin
Hi Allfive,

About Joomla 1.5 in a server with PHP 5.x - I would assume it will work, however without testing I cannot guarantee. Do a backup of your site before and after any change (for security reasons).

We have a class that will help you to update Joomla 1.5 to 3: www.ostraining.com/courses/class/joomla/update-1?task=view - please give a try and let us know if you need something else

In addition, we published a post about switching to a newer PHP version in shared hostings - www.ostraining.com/blog/joomla/security-joomla-3-4-7/

Kind regards,
Valentín

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

Join today and get access to 1,000's of books and videos. Learn WordPress, Drupal, Magento, Joomla and more! Sign up today!