SPECIAL OFFER: Only $69 for access to everything in OSTraining for 1 year! You save $75! 
Join today and get access to 1,000's of books and videos. Learn WordPress, Drupal, Magento, Joomla and more! Sign up today!

OSMap not working

5 years 11 months ago - 5 years 11 months ago #120226 by mlehr
OSMap not working was created by mlehr
Hai,

1. OSMap is not working anymore. I get the message: "
XML-parsefout: geen element gevonden
Locatie: http://sitesuccess.nl/index.php?option=com_osmap&view=xml&tmpl=component&id=1
Regelnummer 243, kolom 1:
" I use the latest version (3.1.8) and Joomla 3.4.6. Deinstalled component and plugins, but no effect. Somehow I cannot deinstall libraries of OS.
How/where can I fix that?
2. I use EasyBlog. This does not have the URL's in a menu. How can I add EasyBlog posts to OSMap?

Regards, Maurice

Maurice

Please Log in to join the conversation.

5 years 11 months ago #120229 by Valentin
Replied by Valentin on topic OSMap not working
Hi Maurice,

Install Easyblog plugin to support OSMap.
See if makes a difference.

Kind regards,
Valentín

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 11 months ago #120234 by mlehr
Replied by mlehr on topic OSMap not working
OK, Vallentin, I installed that plugin.

Please answer my question number 1, because that has nothing to do with EasyBlog.

Maurice

Please Log in to join the conversation.

5 years 11 months ago - 5 years 11 months ago #120236 by Valentin
Replied by Valentin on topic OSMap not working
Edit this file: github.com/OSTraining/OSMap/blob/master/...ml/view.html.php#L64
In your site is located in: components/com_osmap/views/xml/view.html.php
Change that line to:
@ini_set('display_errors', 1);

Refresh the sitemap: sitesuccess.nl/index.php?option=com_osma...&tmpl=component&id=1
Then, reply here so I can check

Kind regards,
Valentín

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 11 months ago #120261 by mlehr
Replied by mlehr on topic OSMap not working
I just did all that and created a new Sitemap: sitesuccess.nl/index.php?option=com_osma...&tmpl=component&id=3
Please check.

Regards, Maurice

Maurice

Please Log in to join the conversation.

5 years 11 months ago #120267 by Valentin
Replied by Valentin on topic OSMap not working
Hi Maurice,

Go to Menus > Your Menu
Look for the menu item after "Laatste"
Which menu item type is?

By the way, the error tell us it's coming from EasyBlog. Check source code of the sitemap to see it:

<b>Fatal error</b>: require_once(): Failed opening required '/home/sitesucc/public_html/components/com_easyblog/constants.php' (include_path='/home/sitesucc/public_html/plugins/system/shlib/shl_packages//ZendFramework-1.11.7-minimal/library:.:/usr/local/php56/pear') in <b>/home/sitesucc/public_html/plugins/xmap/com_easyblog/com_easyblog.php</b> on line <b>242</b><br />


Kind regards,
Valentín

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 11 months ago #120275 by mlehr
Replied by mlehr on topic OSMap not working
Hai Valentin,

I am not quite sure if I understand you correctly...Is this maybe the info you need: "EasyBlog » Voorpagina blog lay-out"
(in English: EasyBlog >> frontpage blog lay-out)

Regards, Maurice

Maurice

Please Log in to join the conversation.

5 years 11 months ago #120276 by Valentin
Replied by Valentin on topic OSMap not working
If you check the source code of the sitemap, the last rendered menu item is "Laatste" -> sitesuccess.nl/Blog/Laatste - which probably means the next menu item broke the sitemap.

Be sure EasyBlog is updated in your site, last version is 5.0.16
Also, check the EasyBlog plugin for OSmap is updated too

After checking that. If the issue persist, disable the OSMap EasyBlog plugin.

Kind regards,
Valentín

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 11 months ago #120278 by mlehr
Replied by mlehr on topic OSMap not working
I see.

Last versions + disabled EasyBlog plug-in, but no luck.
Please check again.

Maurice

Please Log in to join the conversation.

5 years 11 months ago #120279 by Valentin
Replied by Valentin on topic OSMap not working
Very odd. Checking the error, still there is a reference to the EasyBlog Xmap plugin; by disabling it that error should dissapear:

/home/sitesucc/public_html/plugins/xmap/com_easyblog/com_easyblog.php


Rename the folder plugins/xmap/com_easyblog/ to "com_easyblog-disabled"
Install the OSMap EasyBlog plugin instead: stackideas.com/blog/osmap-plugin-for-eas...ailable-for-download

I noticed that last version is in osmap folder, instead of xmap.

Kind regards,
Valentín

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

5 years 11 months ago #120280 by mlehr
Replied by mlehr on topic OSMap not working

Install the OSMap EasyBlog plugin instead: stackideas.com/blog/osmap-plugin-for-eas...ailable-for-download

Why again? I already installed this plugin after your first suggestion...

Maurice

Please Log in to join the conversation.

5 years 11 months ago - 5 years 11 months ago #120281 by Valentin
Replied by Valentin on topic OSMap not working
The plugin you have is installed in this location: plugins/xmap/com_easyblog/
The one I suggested would be installed in: plugins/osmap/com_easyblog/

Hopes the clarification helps

Kind regards,
Valentín

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
The following user(s) said Thank You: mlehr

Please Log in to join the conversation.

5 years 11 months ago #120293 by mlehr
Replied by mlehr on topic OSMap not working
Thanx, works now :-)

Regards, Maurice

Maurice

Please Log in to join the conversation.

5 years 11 months ago #120297 by Valentin
Replied by Valentin on topic OSMap not working
You're welcome, Maurice!

Kind regards,
Valentín

Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining

Please Log in to join the conversation.

Join today and get access to 1,000's of books and videos. Learn WordPress, Drupal, Magento, Joomla and more! Sign up today!