Start Online Training

Get access to all our video classes and support. That's 1818 training sessions in Joomla, Drupal, WordPress, Coding and SEO.
Prices start only at only 25 USD per month

Testimonials

Testimonials OSTrainingThanks for the great training! I'm normally more inclined to be a visual than a coder, and these videos have began removing the wall of fear that has kept me from learning coding. Working with WordPress got me interested, and I'm so glad I found you all! "

~ Caleb Walker

 

Start a FREE 7 day trial! Get training videos and books, plus expert support:  

TOPIC: 404 Error with Artisteer template and Joomla 2.5

404 Error with Artisteer template and Joomla 2.5 1 year 4 months ago #60322

Hello, I create my site's template from Artisteer and have had no issues in the past, but when I imported the content on a template it made my site have a 404 error. So I tried to uninstall the template and then re-install it. The problem is that it won't install the template. I keep getting this error: There was an error uploading this file to the server.

Should I check with the server my host is using? I'm not even sure what I would ask them...

I use J! 2.5.8.
~M.Q~
Last Edit: 1 year 4 months ago by steve.
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60328

  • tessa
  • tessa's Avatar
  • OFFLINE
  • Posts: 4073
  • Thank you received: 144
madamquill wrote:
Hello, I create my site's template from Artisteer and have had no issues in the past, but when I imported the content on a template it made my site have a 404 error. So I tried to uninstall the template and then re-install it. The problem is that it won't install the template. I keep getting this error: There was an error uploading this file to the server.

Should I check with the server my host is using? I'm not even sure what I would ask them...

I use J! 2.5.8.


Hi madamquill,

Does this issue only happen on this server? Have you tried a different server or localhost?
Warm Regards,

Tessa Mero



Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60330

Hi Tessa,

Recently my hosting changed my server because on the old server, my site both front and backend was running slow. And I had no template issues with the old server and until I imported the content for my template all was well. I don't have it run on a localhost.
~M.Q~
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60333

  • tessa
  • tessa's Avatar
  • OFFLINE
  • Posts: 4073
  • Thank you received: 144
madamquill wrote:
Hi Tessa,

Recently my hosting changed my server because on the old server, my site both front and backend was running slow. And I had no template issues with the old server and until I imported the content for my template all was well. I don't have it run on a localhost.

Does each server have different PHP versions?
Warm Regards,

Tessa Mero



Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60335

That's not something I am able to tell. At least not that I'm aware of. My hosting (rochen) just did everything. The only thing I had to do was change the nameservers with my domain.
~M.Q~
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60343

  • rod.m
  • rod.m's Avatar
  • OFFLINE
  • Posts: 492
  • Thank you received: 32
hi,

to look at the key versions of software your site is running on - Log into the Administrator side and click on Site -> System Information. You'll see database, PHP and Joomla version in that window.

It could be that your template is too large (a setting that will need to be fixed by Rochen in your php.ini file).

Let us know what you see when you go to system information ... :)

Rod
follow us on Twitter twitter.com/ostraining
Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60367

Hi Rod, thanks for your reply. Okay so this is what I saw:

PHP Version 5.3.18
Web Server Apache
WebServer to PHP Interface cgi-fcgi
Joomla! Version Joomla! 2.5.8 Stable [ Ember ] 8-November-2012 14:00 GMT
~M.Q~
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60373

  • tessa
  • tessa's Avatar
  • OFFLINE
  • Posts: 4073
  • Thank you received: 144
madamquill wrote:
Hi Rod, thanks for your reply. Okay so this is what I saw:

PHP Version 5.3.18
Web Server Apache
WebServer to PHP Interface cgi-fcgi
Joomla! Version Joomla! 2.5.8 Stable [ Ember ] 8-November-2012 14:00 GMT


Thanks for providing this information.

What was the php version of your last server?

Did you check how much space you have left on your server as well?
Warm Regards,

Tessa Mero



Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60381

Hi Tessa, I don't know PHP of the last version, but my site was pretty new. I was originally using J! 2.5.7 but then upgraded recently. I have tons of space on my server so I don't think that's an issue.
~M.Q~
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60383

  • jmc
  • jmc's Avatar
  • OFFLINE
  • Posts: 1566
  • Thank you received: 133
Hi
Try uploading a free template. Also check that you exported the aristeer template as a joomla 2.5 version.
Regards
Mark
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60526

yeah it's not working. I mean, even the default J! templates that come with the database aren't working. I get this: #404 Component not found

When I try and view the site.
~M.Q~
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60539

  • Nick
  • Nick's Avatar
  • NOW ONLINE
  • Posts: 19320
  • Thank you received: 528
Hi madamquill,

Would you send me some login credentials to This email address is being protected from spambots. You need JavaScript enabled to view it. so I can take a quick look for you? Also, please do two things for me:
1) Include a link to this forum post in the email
and
2) After sending the email, reply to this forum post letting me know you sent the email so that I can check it.

Kind regards,
Nick
Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60541

Hi Nick,

I have sent the email.
~M.Q~
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60613

  • Nick
  • Nick's Avatar
  • NOW ONLINE
  • Posts: 19320
  • Thank you received: 528
Thanks! I replied :)
Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60624

Got it, I updated your access to superuser and backed up everything. We're good to go.
~M.Q~
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60661

  • Nick
  • Nick's Avatar
  • NOW ONLINE
  • Posts: 19320
  • Thank you received: 528
Hi madamquill,

I got rid of your 404 error by going to your main menu then making the "Home" menu item the default menu item. For whatever reason, there wasn't a default menu item set and there needs to be one.

Hope this helps! Could you try installing your template now?

Kind regards,
Nick
Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60667

Thanks Nick, yeah the 404 error is gone but I still can't upload this template. I don't know what the issue is there. So I tried to upload the file to my other site that isn't experiencing any issues and I had the same problem. It won't upload. I get the same error message: There was an error uploading this file to the server.

Do you think this is a matter I should take up with Rochen, my host?
~M.Q~
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60669

  • Nick
  • Nick's Avatar
  • NOW ONLINE
  • Posts: 19320
  • Thank you received: 528
You're welcome!

OK, please send me the template file by email.
Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60673

Awesome! Okay I've sent it to you. Thanks!
~M.Q~
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60675

  • Nick
  • Nick's Avatar
  • NOW ONLINE
  • Posts: 19320
  • Thank you received: 528
Looks like you have to increase your upload_max_filesize as it's currently set to only 2MB (the template installation is 2.5MB). Increase it to 10MB according Rochen's documentation/support and you should be set to go :)
Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60679

That's great! So...where can I change this? I'm in my cpanel and I'm not seeing where I do this. I tried going through the documentation/support links but I'm not seeing exactly how to do this.
~M.Q~
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60681

  • Nick
  • Nick's Avatar
  • NOW ONLINE
  • Posts: 19320
  • Thank you received: 528
Contact Rochen's support as every host is able to do it differently (some through a php.ini file, others through .htaccess, others make the change for you, etc).
Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60682

Ah! I was hoping you'd say that. :)

Mr. Savoy, as usual, you're the best. Thank you SO much for helping me out, I hope this will be resolved finally through my host. Have a wonderful rest of the evening!

Madamquill--
~M.Q~
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60689

  • Nick
  • Nick's Avatar
  • NOW ONLINE
  • Posts: 19320
  • Thank you received: 528
You're very welcome, Madamquill! We're glad to have been of help! :)
Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60690

Yup, it worked. They changed it for me, template loaded just fine. My formatting is all shot to blazes but I can fix that. Thanks again!
~M.Q~
Please become a member of OSTraining to reply to this post.

Template 1 year 4 months ago #60745

  • Nick
  • Nick's Avatar
  • NOW ONLINE
  • Posts: 19320
  • Thank you received: 528
Awesome, glad to hear that! :)
Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

 

Start a FREE 7 day trial! Get training videos and books, plus expert support: