Start Online Training

Get access to all our video classes and support. That's 1818 training sessions in Joomla, Drupal, WordPress, Coding and SEO.
Prices start only at only 25 USD per month

Testimonials

Testimonials OSTrainingI once said you guys put the ! after Joomla, but with the Pro program, it should now be spelled Joomla!! :)"

~ Luis

 

Start a FREE 7 day trial! Get training videos and books, plus expert support:  

TOPIC: joomla COM_CONTENT__FILTER_LABEL Error

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39531

nyp25.karmicvisionsdesign.com/index.php/...fe-purpose-discovery

Whenever I active the moofaqs module I get this information under it:
joomla COM_CONTENT__FILTER_LABEL

The extension developer said he didn't think it was because of it after he looked at it. I tried one of the base templates and the issue still exists so not sure what might be causing it.

It's an original install of 2.5.1.

Thanks,
Darlene
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39532

  • tessa
  • tessa's Avatar
  • OFFLINE
  • Posts: 4073
  • Thank you received: 144
It might be a bug in the language code.

Can you please make a backup of your file in case it doesn't work. This was the only thing I was able to find as a fix:


In /language/en-GB/en-GB.com_content.ini (In 2.5)
line 53 is:
COM_CONTENT_TITLE_FILTER_LABEL="Title Filter"

change to:
COM_CONTENT__FILTER_LABEL="Title Filter"

Note between CONTENT and FILTER there is a double underscore

Let me know what happens if you change this?
Warm Regards,

Tessa Mero



Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39537

I made the change, purged the cache and don't see any change.

Thanks,
Darlene
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39559

  • Nick
  • Nick's Avatar
  • OFFLINE
  • Posts: 19328
  • Thank you received: 528
Hi Darlene,

Try adding COM_CONTENT__FILTER_LABEL="Title Filter" to language/overrides/en-GB.override.ini

This is only to troubleshoot the issue and is not an end-all solution. Once you identify the source of the bug, you'll have to report it either to the develop or the Joomla Bug Squad so that they can get it fixed for you.

Kind regards,
Nick
Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39589

I made that change but it didn't have an effect. Any other suggestions?
Thanks,
Darlene
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39591

  • Nick
  • Nick's Avatar
  • OFFLINE
  • Posts: 19328
  • Thank you received: 528
Can you enable the moofaqs module so that we could have a quick look?

Kind regards,
Nick
Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39594

nyp25.karmicvisionsdesign.com/index.php/...fe-purpose-discovery
It already is, it's the sliders right above the odd code at the bottom of this page.

Thanks,
Darlene
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39595

  • Nick
  • Nick's Avatar
  • OFFLINE
  • Posts: 19328
  • Thank you received: 528
Thanks Darlene! I guess I'm not seeing any "COM_CONTENT__FILTER_LABEL" then. Try clearing your browser's cache and then have another look. If that doesn't help, what browser and browser version are you using? It works fine for me in Google Chrome.

Kind regards,
Nick
Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39597

I cleared it again and it's still showing. Using Firefox 9.0.1.

Thanks,
Darlene
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39599

  • Nick
  • Nick's Avatar
  • OFFLINE
  • Posts: 19328
  • Thank you received: 528
Hi Darlene,

It's not showing for me in Firefox 10.0.2 either. Could you try a different browser and see if it's an issue in there? Also, please upload a screenshot of where it's occurring.

Kind regards,
Nick
Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39600

Attached is a screen shot. I tried it in IE9 also and still see it.

Thanks,
Darlene
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39602

  • Nick
  • Nick's Avatar
  • OFFLINE
  • Posts: 19328
  • Thank you received: 528
Hi Darlene,

Perhaps I'm thick, but I'm not seeing "COM_CONTENT__FILTER_LABEL" anywhere in your screenshot either.

Kind regards,
Nick
Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39605

Okay I see the confusion, that error line item was showing up at the top of the area circled in red. Since I made the ini file changes that part isn't showing up but the rest is. Everything in the red circle shouldn't be there. If I disable the module it goes away and appears when I enable it. That's why I thought it was tied to the module (ie. extension) but that extension developer said he couldn't find it tied to the module.

Hope that makes more sense.
Thanks,
Darlene
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39607

  • Nick
  • Nick's Avatar
  • OFFLINE
  • Posts: 19328
  • Thank you received: 528
OK, that makes a lot more sense now :)

Please enable the module positions finder and then see if that part shows up in a module position or not. Here's a tutorial on how to do that:
www.ostraining.com/blog/joomla/how-to-fi...-joomla-16-template/

Kind regards,
Nick
Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39609

It's turned on now and I checked and it appears to be part of that module position.
Thanks,
Darlene
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39613

  • edandrea
  • edandrea's Avatar
  • OFFLINE
  • Posts: 3094
  • Thank you received: 7
Just checking. Are you saying it works correctly now and the problem is fixed?

Ed
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39625

No Nick asked me to turn the module positions finder on and see if it was showing in that module position. And yes, it's turned on and yes it is showing in the position. It is still showing the extraneous information.

Thanks,
Darlene
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39629

  • Nick
  • Nick's Avatar
  • OFFLINE
  • Posts: 19328
  • Thank you received: 528
Hi Darlene,

In module manager, check to see which modules you have loaded in the content-bottom-a module position by using the module position filter.

Kind regards,
Nick
Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39633

  • edandrea
  • edandrea's Avatar
  • OFFLINE
  • Posts: 3094
  • Thank you received: 7
I'm looking at this and I think the problem is tied to the menu item type. If you select a category list type for example, in the basic parameters you have the option to show or hide the filter.

Seems like you should be able to show or hide the filter when choosing a moofaq menu type as well.

I went to the moofaq demo site and they don't seem to have that as an option in their menu item configuration. I think they could tell you how to fix it, but maybe they didn't understand the problem?

Can you confirm that I am correct as far as the actual problem. You just don't want the article filter to show at all?

Thanks
Ed
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39634

The one MOOFAQs module is the only thing in the position, published and unpublished.

Thanks,
Darlene
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39635

  • edandrea
  • edandrea's Avatar
  • OFFLINE
  • Posts: 3094
  • Thank you received: 7
When you do as Nick suggests and view the page using ?tp=1 you can see that there are two outputs in that module position. The moofaqs and and article list with a filter.

Either two modules are active in that same postion or moofaqs isn't acting right.

Ed
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39637

The menu type for this page is a single article so I'm not really seeing what you are referencing regarding the filter.

The only thing that is suppose to show in the module position is the sliders not the repeat information beneath it (article filter).

It's only when I turn publish the module that it appears. In my email with moofaqs they don't know and think it's a different extension causing it.

Thanks,
Darlene

Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39639

  • Nick
  • Nick's Avatar
  • OFFLINE
  • Posts: 19328
  • Thank you received: 528
Hi Darlene,

Check the component's and modules options and look for any options that deal with categories and make sure they are set to "hide" rather than "show".

Kind regards,
Nick
Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39640

This is what it looks like as it is set now. I tried a lot of variations but to get the sliders this appeared to be the one needed.
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39641

  • edandrea
  • edandrea's Avatar
  • OFFLINE
  • Posts: 3094
  • Thank you received: 7
If it's an extension conflict, the best way to resole it is to turn off the extensions one by one until the problem goes away.

Do you have duplicate test site with its own database you can use for testing?

I attached a screen shot of what I see when I view it using tp=1. You'll see it shows overlapping content. Either two modules or one module acting funny. You'll have to track down the source of the conflict to figure out how to fix it.

I wouldn't always believe the first answer I got from the developers. Unless it's a known problem, or they have actually gone through the complete trouble shooting process, they are just guessing.

Let's track it down.
Cheers,
Ed
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39642

I think what you are referencing as overlapping was a fixed footer that I just turned off so you can look again. It's not really the same position.

Thanks,
Darlene
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39645

  • Nick
  • Nick's Avatar
  • OFFLINE
  • Posts: 19328
  • Thank you received: 528
Hi Darlene,

Please write down your current settings then try switching the view option to something else and see if that helps on the frontend. Try different combinations for the settings and see if that helps. I'm guessing that module is picking up the category's options, so you'll likely have to end up changing the category options for the category in category manager.

Kind regards,
Nick
Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39647

  • edandrea
  • edandrea's Avatar
  • OFFLINE
  • Posts: 3094
  • Thank you received: 7
What module is generating the list in the attached image. That module is also generating the filter form. There would need to be a line of code in that modules php file asking Joomla to show the filter. If you can figure out which module that is you can comment out the code.

I see two displays in this position. One is the sliders, and one is the list of articles. Whatever is generating the list of articles is also generating the form.

The standard template style for lists includes the filter, unless it's turned off in a control like the one that is included with menu items. Seems the only module in that position is the moofaq module. So there has to be a line in the php code of moofaq asking that filter to show up.

If you disable moofaq's does it still show?

If there is another module at work, conflicting with it, that could cause it to show. But if you turn off moofaq and it goes away that would point to moofaq as the source of the problem.
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39648

That's what I thought it had to be tied because when I turn off that module the filter goes away. He wasn't very helpful for a paid extension but I'll see if I can find the code you are referencing.

Thanks,
Darlene
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39655

  • edandrea
  • edandrea's Avatar
  • OFFLINE
  • Posts: 3094
  • Thank you received: 7
Hi Darlene,

Nick and I were just chatting about your problem. I first suggested it was a setting in menu item type, because that's where the control is for that. But Nick reminded me there is a display option in Article options for turning on the filter display.

This should only turn off the filter, but you might still get the redundant list. Anyway it's worth a try before you hack away at the code.

I attached a screen shot.

Content>Category Manager> Options Icon. Check your category settings as well. Since moofaq is borrowing from the joomla native function.

Ed
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39657

  • edandrea
  • edandrea's Avatar
  • OFFLINE
  • Posts: 3094
  • Thank you received: 7
PS. There is also an option on the category as well. Try different choices from the alternative layout options.

If all the setting changes fail, then it definitely lies with moofaq and the module itself.

Ed
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39805

I believe I tried all of the recommendations and I do believe it's a moofaq issue. The best resolution the developer gave me was to us a custom html module and use their plugin in it. That appears to work, not the ideal fix but it's better than nothing. Hopefully some day the actual issue will be determined and resolved.

Thanks for all the help!
Darlene
Please become a member of OSTraining to reply to this post.

joomla COM_CONTENT__FILTER_LABEL Error 2 years 1 month ago #39899

  • Nick
  • Nick's Avatar
  • OFFLINE
  • Posts: 19328
  • Thank you received: 528
You're welcome, Darlene! We're glad to be of help and we're even more glad that you found something that works for you! :)

Kind regards,
Nick
Follow us on Twitter - twitter.com/OSTraining
Like us on Facebook - facebook.com/ostraining
Please become a member of OSTraining to reply to this post.

 

Start a FREE 7 day trial! Get training videos and books, plus expert support: